Splashtop uninstalling

This is not BYO Splashtop. When I attempt to use splashtop to connect to an asset I receive the error “We’re having trouble connecting you with Splashtop. Splashtop says: The streamer isn’t online.” I can use the backgrounding tools → Remote desktop to access the asset. When I check the device history I see that it says that “Splashtop Streamer was just uninstalled” the day after I installed syncro. I have uninstalled syncro through the apps and features, then reinstalled it, still no splashtop. I have ininstalled syncro, removed the asset from syncro, then reinstalled. Still no Splashtop (I waited a week to be sure.) The user of the PC is sure they did not uninstall it. How do I get it installed and get it to stay? This is only affecting one asset out of 226 (That I have noticed at least.)

Make sure your policy is set to deploy Splashtop. I would then move the machine out of said policy, save, then move it back in and save again. This should trigger Splashtop to reinstall.

Does the Asset need to be on/online for this process to work? It is currently offline. If I remove the Policy and add it now will splashtop install when it boots or do I need to do the steps with the asset online? (It is at another location and powered down at the moment.)

Most things queue if the asset is offline until it comes back online. I’m not sure of changing the policy and the changing it back would queue those changes in that order. I would think they would. Worth a shot.

Also, I did see a script floating around that reinstalls the Streamer which is what controls the remote access anyway.

You can get a “generic” installer from here: DOWNLOADSTART - Splashtop Inc.

So scripting that to reinstall would probably also fix the issue.

This will reinstall/update the Streamer. Works for most cases.

Import-Module $env:SyncroModule
$workingdir = "c:\temp"
$url = "https://my.splashtop.com/csrs/win"
$file = "$($workingdir)\streamer.exe"

# Test if the working directory exist
    If(!(test-path $workingdir))
        {
        New-Item -ItemType Directory -Force -Path $workingdir
        }

# Download
    Invoke-WebRequest -Uri $url -OutFile $file
    
# Install
        start-process -wait -Filepath $file -ArgumentList "prevercheck /s /i hidewindow=1"
        Start-Sleep -s 3
        Write-Host "Deleting Installer"
        Remove-Item -path $file

Anyone know if this script still works and does it require any modification? Apparently the Splashtop Streamers require an update and are showing offline errors now.

Script still works fine, just used it this week.