Splashtop Streamer Stealing Focus

Hi,

Today I have noticed that something is stealing focus on my Mac. If I am typing in Safari for example, the window will suddenly become inactive and I am unable to keep typing unless I click in the window again. I have used a time-tracking app to see which app is active when this happens, and it is Splashtop Streamer. At least one of my clients has noticed this behaviour as well.

Every few minutes, the active app on my Mac becomes Splashtop Streamer so I have to click back into whatever I was doing to continue. Splashtop steals focus just for a second.

I have completely uninstalled Splashtop Streamer, and the issue was resolved. As soon as I reinstall it, the issue returns.

Has anyone else experienced this or is there any advice on resolving it please? So far it has been noticed on an M1 Mac Mini, and an M1 14" MacBook Pro, both running the latest Monterey.

Thank you.

1 Like

I’d reach out to Splashtop support directly on this one. Sounds potentially like a software issue/conflict.

I’m seeing the same thing across all my apps losing focus but staying on the app the typing window drops off focus and the computer beeps at me. I was thinking it’s either Syncro or Sophos since those are the two things running along with the system… never thought it was possibly Splashtop.

I’m on Monterey 12.3.1 and Intel i9 MBP

I’ve already logged a ticket with them. #257343 Apparently it’s to do with the way that Syncro is interacting with the Streamer app. I have logged a ticket with Syncro as well. This is Splashtop’s reply…

Hey Matt,

We saw that Syncro keeps sending URI requests to our Streamer which causes this behavior.
This has nothing to do with us but with Syncro’s way of sending URI requests.
Our team does not know why they would do that.

Could you ask/tell Syncro the following?

  • Why do they need to send URI calls every 5 minutes?
  • They can use /Applications/Splashtop Streamer.app/Contents/MacOS/srs_uri for URI calls, I think this method can avoid the Streamers behavior of stealing the focus.

Thank you and I am looking forward to your reply!

Regards,
Splashtop Business Support Team

2 Likes

Ah thanks for that update @matt12 that’s good info. @Andy back to you guys then it seems?

This is a very strange one. I raised it internally just now.

1 Like

Adding to the conversation, we’ve seen the exact same issue with Splashtop Streamer in our environment. Running the script from this stack exchange thread helped us to ID the culprit.

https://apple.stackexchange.com/questions/123730/is-there-a-way-to-detect-what-program-is-stealing-focus-on-my-mac#148094

Does anyone have a script to help remove splashtop in bulk? This is hitting all of our users pretty constantly.

I haven’t made a specific script but this series of Terminal commands will completely remove Splashtop, you could make a script from them:

sudo killall Splashtop\ Streamer;
sudo rm -rf /Applications/Splashtop\ Streamer.app;
sudo rm -rf /Library/Application\ Support/Splashtop\ Streamer;
sudo rm /Library/Application\ Support/com.splashtop.streamer*;
sudo rm /Library/LaunchAgents/com.splashtop.streamer*;
sudo rm /Library/LaunchDaemons/com.splashtop.streamer*;
sudo rm ~/Library/LaunchAgents/com.splashtop.streamer*;
sudo rm ~/Library/Application\ Support/com.splashtop.streamer*;
sudo rm -rf ~/Library/Application\ Support/Splashtop/Splashtop\ Remote;
sudo rm -rf /Users/shared/SplashtopRemote;
sudo rm -rf /Users/shared/SplashtopStreamer

You will also need to create a new policy in Syncro that has remote access unticked, otherwise you will remove Splashtop and the Syncro agent will just reinstall it again. So I guess the steps would be:

  • Change all Mac agents to a new policy without remote access
  • Wait for agents to update to new policy automatically after a while, or run sudo /usr/local/bin/syncro restart in a script to force them to restart
  • Run above commands to strip Splashtop

Then once Syncro fixes this issue you can just change all the agents back to the original policy that includes remote access and Splashtop should be automatically reinstalled fairly quickly. The Mac should also remember the Full Disk Access/Screen Recording/Accessibility/Microphone permissions, so you shouldn’t need to re-tick those.

Actually thinking about it, if the issue is that Syncro are making too many calls to Splashtop then you probably don’t need to uninstall Splashtop at all, just leave it as it is but change all of the agents to a policy that doesn’t include remote access, and I would assume the Syncro agent would then stop calling Splashtop Streamer. You can then easily change the policies back once it’s fixed. @Andy would you agree?

Took me lots of testing to figure out it was Syncro causing this and saw this post. Now I have to get this patched for all of our clients.

Thank you Sam

Yes this would likely be the stopgap, just be sure you have a secondary remote access tool in place before doing that if need be.

Add me to the list of unhappy users. I’ve fielded WAY too many calls from customers that are experiencing this now. They aren’t blaming me - yet - but it’s got to be solved ASAP. Turning off remote admin isn’t really a practical solution, since that’s one of the primary reasons for Syncro to be installed on the machines in the first place!!

Totally agree, removing RA isn’t a great solution. Our engineers are investigating the issue and working toward a resolution. I do not have an ETA for you currently, though.

1 Like

I agree, I am in a fortunate position where we have all of our agents in Connectwise and I was actually in the process of migrating them into Syncro/Splashtop. This has made me seriously reconsider though, as I have never had any difficulties at all with Connectwise and it has been nothing but an ever-growing list of problems with Splashtop, that Syncro have so far been unable to resolve even one of. Splashtop as a standalone product is an excellent solution, there is something about the limitations imposed on this implementation that has resulted in an endless streams of issues.

I think I can move back to VPN/Apple Remote Dektop for a bit but one of my bigger clients just called and said all their Catalina machines are doing it as well and making medical notes is driving them bonkers… They’re not happy. I was really hoping it was just my machine but I’m getting calls now. Hopefully this is remedied soon!

Have we verified this is a Syncro Issue because I am seeing similar complaints on the internet about this and Mac OS Monterey and Bluetooth devices. If you disable all Bluetooth devices the problem goes away, or at least something to test.

Here is a post I found:
Active window loses focus | MacRumors Forums and
https://twitter.com/longzheng/status/1507137132368101382

This is a verified Syncro issue.

Hey all. I can confirm that disabling the remote access function within your workstation policy fixes the issue (for us at least). Unfortunately, this also removes the ability for remote connection, so hopefully a patch will come out soon. @sam5, thanks for the suggestion.

This worked for us as well. Thank you. Do we have an ETA on when this will be fixed?