Syncro System Status:

Our New Mac Agent Is Now Live!

Hey everyone! Our new Mac agent has officially been released, and now includes full scripting support (script variables, required files, api commands) as well as support for our native Splashtop RMM integration.

Full a full accounting of what our agent supports you can reference THIS KB document.

3 Likes

The table doesn’t list the native Splashtop for either the Windows or Mac agent, just BYO stuff.

Cause it’s native :slight_smile:

Good callout, I will get it added.

Excellent News! I’ll begin testing immediately!

1 Like

I think I got a preview of this. THis morning we happened to be onboarding a new Mac and when adding permissions we noticed “Splashtop Streamer” in the System Preferences.

Can’t wait to test it out!

3 Likes

What is the version of the latest agent ?

I believe it’s 0.28.401.

@Andy There are no script variables for “Mac Script”. Kind of an evil tease as this is one of the biggest things that has been killing me about the Mac agent. When will we see Script Variables for “Mac Script”? Or if there’s a different way to handle the variables than setting them in the script UI, can you point us to the documentation? Both the current UI and the current documentation have script variables as a Powershell only feature …


.

It’s there. I think you probably just need to clear your browser cache, refresh your page, and then I bet that resolves it.

No cache-clearing necessary. When I posted the above it wasn’t available on any Mac Script, new or existing. My browser is still open and in the same Syncro login session. I navigated to a Mac Script and its there. ¯\(ツ)

Weird. Glad it’s working for you now.

Tried it on one Mac so far. Worked great, including Splashtop. But then I upgraded that Mac to Monterey (12.1) and it didn’t run on boot. Re-installed agent again and now I see the screenshot in the asset overview page, but trying to run Splashtop fails with session password incorrect.

Session password issue should just be a sync issue. May need some time, unless it’s been more than 6 hours.

Thanks. A reboot cleared it up. Syncro loaded at boot this time and Splashtop worked. I wonder if after a major OS upgrade, the “first run” changes how things startup enough to have caused that problem. (stabbing in the dark here)

Really excited this is finally happening. I had previously installed splashtop business on each mac and had clients have to manually run it and recite the 9 digit code to me.

1 Like