Splashtop remote access FROM linux (workaround)

I’ve been keeping a windows machine around just to run splashtop viewer for remote clients for awhile now, figured I’d finally get around to fixing the issue. The viewer runs OK with wine in linux, you just have to forward everything from the browser to it before it does anything.

Steps are as follows.

I used the wine PPA, version 6. No idea how well this will work with older versions.

Install your RMM splashtop viewer app with wine as you normally would anything else (I used a 32 bit prefix in the default location, edit as needed). In your editor of choice, make a file called splashtop-viewer.desktop

In the file, paste the following, replacing USERNAME with your home directory:

[Desktop Entry]
Name=Splashtop Viewer
Exec=bash -c 'echo "%u" | sed "s#st-rmm://##g" | xargs wine "/home/USERNAME/.wine/drive_c/Program Files/Splashtop/Splashtop Remote/Client for RMM/clientoobe.exe" "-a"'
Type=Application
Terminal=false
MimeType=x-scheme-handler/st-rmm;

Save the file. Add it to your programs list with:

xdg-desktop-menu install /path/to/splashtop-viewer.desktop

register it as your default handler for st-rmm protocol links:

xdg-mime default splashtop-viewer.desktop x-scheme-handler/st-rmm

Chrome and related programs should just open it when you click the “Remote Access” button now, Firefox may need a little prodding by going to about:config setting a boolean for network.protocol-handler.expose.st-rmm to false, then manually selecting the “Splashtop Viewer” option in the “choose application” popup that you see when you click the link.

Seems to work ok, with what I’ve done with it for the last two days.

Since syncro says “you can’t do this from Linux” I figured a solution might be appreciated by some folks.

Edit: it’s a good idea to install corefonts using winetricks. Some of the text may be missing without it.

6 Likes

That’s awesome! I’ll have to try this. Honestly, Syncro/Splashtop is one of the only reasons why I’m not using Linux currently.

I tried this with a VM and didn’t seem to work.

Thanks so much for this, I was able to get this working great within my Debian based system.

This worked for me, Thanks!

1 Like

Got this working on Ubuntu 22.04 with wine64 from stock repository! Thank you so much!

I know this thread is old but the solution does not seem to work for me on Linux Mint with Ciinnamon desktop.

As a rather casual Linux user for decades I’v decided I had enough with Windows but I still want to support Windows users. My journey shouldn’t be too hard except for this part.

There is couple of gaps in this great solution for rookies like me :slight_smile:

Anybody wants to pitch in and elaborate how they’ve done it ? That would be awesome !

Thanks to all

I got it working.

You may have to modify Program Files to Program Files (x86) depending on your environment.