SNMP OIDs producing “Not Found” as a result on the details pane

I’ve had a ticket open with my SNMP problems for over a year now, and I continue to have the same issue. Nearly every SNMP device I add, will show green checks on each of the OID’s I’m monitoring, in the “SNMP Details” pane. However, when I save the changes and go back to the asset overview, the same OIDs that just produced a result on the details pane, show “Not Found”.

Is there any ETA to a resolution for this?

I have noticed a delay of no more than a few minutes and then they update. Check your SNMP ver for that device IIRC v1 or v2 made a difference here. I have plenty of SNMP monitors working. Message me if you need more info.

Hi Evan,
So far we have not fixed this yet, nor do we have a timeline. We will let you know when there is an update. Hopefully Jeff’s answer can help in the meantime.

I’ve played around with it too. It’s just fundamentally broken. Somewhere around 50% of the SNMP assets I deploy don’t work properly. The only pseudo fix I’ve found is to trim down the asset to just a couple SNMP checks, then sometimes it works.

To add insult to injury, the attitude from Syncro seems to be something to the effect of “meh, we know it’s broke, but it’s good enough for our sales department to be able to check this box, so we don’t know when or if we’ll get around to fixing it”. Very Frustrating.

1 Like

@evan Please start a new thread with some specifics, share some OIDS you are having trouble with and let’s see what we can get going as a community. I personally am monitoring: APC ATS, APC UPS, Dell iDRAC, Unifi switches, Unifi security gateways 3/4, Axis cameras, HP printers, and Synology NASes. All getting good alerts when action is needed. Pretty much everything is working except for the Canon copiers which aren’t working at the moment. I haven’t investigated them lately as I don’t support them. I have contributed quite a bit to the OIDs repository when SNMP was first added.

I wanted to add one thing I thought of. If you are seeing a green bubble in the SNMP Details, but not after you save it, you may also have the wrong data type. As in String vs Number. You will get green either way, but unless you are looking at the SNMP definition you may not be set correctly.

I appreciate the offer to help, but I’ve worked for hours with support on this trying all sorts of things, and they admit it’s a bug. The most recent asset I’ve played with is a Smart-UPS connected via USB to a Windows 2019 server. I’m using the SNMP service that’s built into PowerChute. Right now I dropped it down to a single OID ( Value type is number (but I’ve also tried saving the configuration w/ String). Hovering over the green check produces a result of 27, which is consistent with other SNMP tools. Once I click Save Changes, I’m left with the “Not Found” message, no matter how many times I hit refresh, or how many times in syncs.

Use the Cyberdrain PS script for a USB attached UPS. (link might not work, I stripped my mspname off the front)

SNMP is for actual network devices. But I would say we are far from fundamentally broken.

@evan, I took a deeper look into your issue.

I was able to find the asset and monitoring device and found an error in our logs:

SnmpService::QueryLive: Unhandled exception: An existing connection was forcibly closed by the remote host

I’d recommend trying to change the monitoring device and see if the values is displayed. If so, there is likely something on the original monitoring device that isn’t allowing the value to be passed along correctly.

I like that as an option for UPS’s attached to desktops, but it doesn’t produce all the information I’m after. Primarily, whether or not the UPS thinks the battery needs to be replaced.

Were any modifications made from your side? Because now this asset is populating properly when monitoring from a different machine, as well as the original one I was monitoring from.

I can check with the team to see if any changes are made. Maybe toggling the monitoring devices reset the connection and resolved the block.

Thanks Frank. Just for the sake of being thorough, my CyberPower UPS’s still have the same issue where the OIDs show green checks in the configuration form, but “No Value” in the asset overview. Also tried toggling different monitoring devices.

Interesting. You’re finding all the edge cases. :sweat_smile:

This error coming up from both of the CyperPower UPSs when trying to retrieve OID information:

[ERR] v1.0.147 SnmpService::PollDevices: Device(XXXXXX): Unhandled SNMP exceptionLextm.SharpSnmpLib.SnmpException: unsupported data type: 1

I have a couple of steps to take:

  1. Double check that the SNMP ports, Version, and Community all match on the UPS side of things.
  2. There may be one OID that is causing this. Try removing one OID at a time and seeing if we can eliminate the rogue OID.

I am curious what OID numbers are getting these errors. shows this as an Integer.

So all of these work individually. However, when they are all enabled, all of them fail.

Check Name OID
Battery Replace Indicator
Input Voltage
Capacity remaining (Depleted < 10%)
Battery Temp
Last Replace Date
Output Frequency
Output Voltage
Input Frequency
Capacity remaining (Low < 50%)
UPS Model Number
UPS Serial Number
Run Time Remaining centiseconds
Output Current (1/10 Amps)
Firmware Revision
Power Rating (VA)
UPS Output Load Percentage

I still think this has something to do with running software providing SNMP results on the same PC as the Monitoring Agent. Are you sure we don’t have a Windows internal firewall issue going on here? Have you tried using as the ip address for the Monitoring Agent and disabling the windows firewall on the machine the UPS is connected to?

Are you able to get good SNMP results from other non PC devices over the network?

I’m not sure what the underlying issue was with the APC problem, but toggling between two different monitoring agents resolved it. So now the same machine is polling the snmp service running on the same device.

The prolonged issue I’ve had for over a year now, is that Cyberpower UPS’s can’t be monitored reliably. The 2 I’m specifically having problems with now have a network card in them, so the monitoring agent and the device listening to SNMP requests are 2 different systems.