Syncro service won't start windows 7

I have successfully installed in multiple machines syncro without a problem, but i seem to have a problem with one machine.
Win7 x64 SP3 (fixed by registry edit)
full windows upates
dot net 4.8
Microsoft Visual C++ 2005-2022 all versions

.exe or .msi both show that are successfully installed, and i can see the syncro app in programms, but the service won’t start.
tried multiple times to uninstall with the syncrouninstaller.bat run as admin, restart machine, and re-install, nothing. tried to download again the .msi and the .exe in case i had a broken file, or smth, but still nothing

the event viewer shows the follwing message.

Unable to start the service. System.Reflection.TargetInvocationException: An exception was thrown by the target of an invocation. —> Autofac.Core.DependencyResolutionException: An exception was thrown while activating Kabuto.Service.HostServiceImpl → λ:System.Collections.Generic.List`1[[Kabuto.Service.Abstractions.ICanInitCleanupAsync, Syncro.Service, Version= 1.0.167.0, Culture=neutral, PublicKeyToken=null]] → Kabuto.Service.Services.ScriptService → Kabuto.Service.Services.Api.SyncroDirectApi. —> Autofac.Core.DependencyResolutionException: An exception was thrown while invoking the constructor ‘Void .ctor(Kabuto.Service.Services.IStorageService, Kabuto.Service.Services.IFilePusherService, Kabuto.Service.Configuration.ISyncroServiceConfiguration, RepairTech.Common .Tools.PersistentWebCall.IPersistentWebCallQueueSingleton)’ on type ‘SyncroDirectApi’. —> System.NullReferenceException: No object reference has been set to an object instance. at Kabuto.Service.Services.Api.SyncroDirectApi…ctor(IStorageService storageS…

Any ideas?

Hi @t.ntallas, I think this will need a ticket, can you submit one with this info and I’ll have support look at why your having this issue.

Hello, thanks for the reply. I just open a ticket!