Trouble running scheduled script - returns module.psm1 error

Hi all

Wondering the best way to resolve this. The customer is running ESET Cloud protect and on some machines when we run a script to find and record the AV version number, it fails with the warning below. Manually tried copying module.psm1 to Scro folder, but disappears when the running script, as AV picks it up and removes it. Now, this only happens on a copy of their machines - rest with the same AV run just fine. Any pointers would be appreciated, as at the moment, can’t see the forest for the tree.

Cheers, Tom.

error> At C:\ProgramData\Syncro\bin\module.psm1:1 char:1
error> + $UUID = $env:RepairTechUUID
error> + ~~~~~~~~~~~~~~~~~~~~~~~~~~~
error> This script contains malicious content and has been blocked by your antivirus software.
error> + CategoryInfo : ParserError: (:slight_smile: , ParentContainsErrorRecordException
error> + FullyQualifiedErrorId : ScriptContainedMaliciousContent
error>
error> Import-Module : The specified module ‘C:\ProgramData\Syncro\bin\module.psm1’ was not loaded because no valid module
error> file was found in any module directory.
error> At C:\ProgramData\Syncro\bin\5e65d8d3-7d9b-40bc-a1ea-dd89dd94023c.ps1:3 char:1
error> + Import-Module $env:SyncroModule -DisableNameChecking
error> + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
error> + CategoryInfo : ResourceUnavailable: (C:\ProgramData\Syncro\bin\module.psm1:String) [Import-Module], Fil
error> eNotFoundException
error> + FullyQualifiedErrorId : Modules_ModuleNotFound,Microsoft.PowerShell.Commands.ImportModuleCommand
error>
Here is the ESET Version Number
9.0.2032.6
error> Set-Asset-Field : The term ‘Set-Asset-Field’ is not recognized as the name of a cmdlet, function, script file, or
error> operable program. Check the spelling of the name, or if a path was included, verify that the path is correct and try
error> again.
error> At C:\ProgramData\Syncro\bin\5e65d8d3-7d9b-40bc-a1ea-dd89dd94023c.ps1:11 char:1
error> + Set-Asset-Field -Subdomain “demo” -Name “ESET Version No” -Value $pro …
error> + ~~~~~~~~~~~~~~~
error> + CategoryInfo : ObjectNotFound: (Set-Asset-Field:String) , CommandNotFoundException
error> + FullyQualifiedErrorId : CommandNotFoundException
error>

You’ll need to whitelist the module file in ESET looks like.

Thanks for responding @isaacg. Had whitelisted file/folder and Syncro as an App - no joy.

Went to the trouble of reinstalling it and still getting the same result. Others PCs running the same setup (i.e. AV version etc) don’t show this behavior - Syncro client simply works on other PCs.

Any other pointers I should consider?

Cheers, Tom.

I don’t know anything about ESET but If it’s like Bitdefender there’s different areas to whitelist things, so you may not have the correct spot. May have to contact their support. Or Windows Defender is butting in instead maybe.

1 Like