Toggl integration stopped working a while back

Hi
When will the Toggl integration be fixed?
I would like to start using it again.

Hi there,
We are reaching out because we detected API usage coming from your Toggl Track
account using the [www.toggl.com(or](http://www.toggl.com(or) toggl.com) domain.
After last year’s rebranding, we released api.track.toggl.com as our new domain for API usage. These
changes were communicated via newsletter and the following blog post. The API Docs were also updated to reflect the domain changes.
We want to inform you that the usage of [www.toggl.com(or](http://www.toggl.com(or) toggl.com) domain for the API will be dropped after ‘June
30th 2021’.
We encourage you to perform the switch to api.track.toggl.com as soon as possible in order to prevent
disruption.
Best wishes,
The Toggl Track Team
support@track.toggl.com

was just talking with support today as time does not inport. They are saying they fixed it but it’s still broken for us too.

Hey miles
Can confirm I am experiencing the same as you.
Clicking “Toggl Import” results in a popup “Time Entries loaded successfully - view the log to see them”

View log shows no time entries.

They fixed it by removing it from the supported integrations on the website. lol

Toggl changed some things up on their end that broke our integration and our developers did resolve the issue. I just verified by setting up Toggl on an account and successfully imported time:

You can go to ‘View Log’ to view the entries after they import or refresh the screen. The entries didn’t show until the page was refreshed for me. Here were my exact steps:

  1. Entered Toggl API key in the Toggl app card in the Syncro App Center.
  2. Make a new Syncro Ticket.
  3. Start a timer in Toggl and use the project that the Syncro integration created during ticket creation.
  4. Stop timer after some time was logged.
  5. Go to Syncro ticket and select ‘Toggl Import’ button.
  6. Select ‘View Log’ to see recorded time.

If this doesn’t work, reset the Toggl API key and try again.

Hi Frank

Yes that seems to work now after resetting the api key.

Thanks

Shane

1 Like

Office Tv Youre Welcome GIF by The Office