Supported Windows OS versions

Our software requires Windows 7 or newer** (Windows Server 2008 R2 SP1, Windows Server 2012 R2, Windows Server 2016, Windows Server 2019, click here for specifics.

We also require version 4.6.2 or higher in order to install Syncro, so if the OS cannot update/install this .NET version, you will not be able to install Syncro on the machine.