Splashtop Permissions

Anyone know how to get Splashtop working for Syncro on macOS High Sierra? The instructions say to click on the gear in top right corner, but as you can see in screenshot there is not one. Any ideas?

I have an old Mac mini server here running High Sierra and hit the same issue. I strongly suspect Splashtop won’t run - the privacy permissions model is quite different than later OS versions. On the other hand, it worked flawlessly on my MacBook Pro running Big Sur. My mini is at the last supported OS and is here for various reasons. If I had a client on a macOS version that old, I’d encourage them to update it/replace the hardware.

Confirmed as well. No gear, no permissions, no Splashtop on High Sierra Machines. Yet.

This appears to be an issue with 10.13 and 10.14. Devs are aware and are looking into it.

I went around and attempted to install on a number of macs in our office last night. None were successful.

On the Big Sur machine, I could not get it to detect that I had given Full File Permissions, but screen recording permissions were detected and acknowledged. It will not show a recorded image in the asset of the screen and will not connect remotely.

On the High Sierra Machine, it recognized that it had full disk permission but not that it had screen recording permission. In this version, neither of those exist in the privacy tab so it’s presumed you can just have them if you install with admin privileges. I can see the screen recording in the asset but I can’t remote to that machine.

On one of the Catalina machines, it was successfully installed, I was able to set the permissions and it shows a recorded image of the screen. But I can’t connect to it remotely.

On the other Catalina machine, it struggled to install, I had to remove it and reinstall it, and it kept taking FOREVER at the last step where it ran the script, often showing up in the assets and syncing then aborting and going offline. It’s running now but like the first Catalina machine I can’t remote to the machine but it’s not showing a recorded image either.

Anyone who has added proper permissions but is still getting a permissions error, definitely send us a ticket at help@syncromsp.com - It seems like this may be specific to some versions but not others. Good information to include…

  • A link to the Asset.
  • A screenshot of the permissions you enabled.
  • A screenshot of your error.

Might be doing a little sifting through differences in each system so these details will help greatly!

Not getting a permissions error, as you can see in above post.

For the ones where remote access isn’t working did you give the splashtop permissions ? Option key > Syncro Icon > Grant Splashtop Permissions.

I have another thread about syncro not recognizing that I had provided full access permissions. this prevents splashtop from working.

1 Like

I’m having the exact same issue as your first paragraph.

I am giving the full disk permission but the agent installer isn’t recognizing that I’ve given the permissions.

It does recognize on the screen recording though.

Mike

A new agent update went out today. Please try uninstalling any “stuck” agents in the state described here, and then reinstall using the new agent and let me know if that resolves the issue.

1 Like

Did not fix the issue on 12.1 Monterey. Still does not detect that full permissions have been enabled.

Developers are looking into issues relating to 12.1 based on multiple reports.

Hi @eddie
This issue has been resolved and users are reporting that it is working as expected - if you are still having this issue, please send us more details by creating a Support ticket with

  • A link to the Asset.
  • A screenshot of the permissions you enabled.
  • A screenshot of your error.