Splashtop. Communication Error

Since this morning, i have been getting splashtop error when trying to remote into client pc.

Communication error

We’re haviing trouble connecting you with splashtop. Splashtop says: The streamer isn’t online.

Was working fine yesterday and this morning getting this on all my devices (WiFi and 5G).

This isn’t anything to do with your device, this is saying the Streamer and Syncro are not able to communicate. You could try restarting the service, restarting the system, or I usually just run this to reinstall/update the Streamer and it fixes it.

Import-Module $env:SyncroModule
$workingdir = "c:\temp"
$url = "https://my.splashtop.com/csrs/win"
$file = "$($workingdir)\streamer.exe"

# Test if the working directory exist
    If(!(test-path $workingdir))
        {
        New-Item -ItemType Directory -Force -Path $workingdir
        }

# Download
    Invoke-WebRequest -Uri $url -OutFile $file
    
# Install
        start-process -wait -Filepath $file -ArgumentList "prevercheck /s /i hidewindow=1"
        Start-Sleep -s 3
        Write-Host "Deleting Installer"
        Remove-Item -path $file

Can someone mention how to run this?

  • Copy the Above

  • Scripts > New Scripts

  • Pate it in > Name it > Save it

  • Go to the asset page

  • Select the scrips tab > Add to Que

  • Select the script name you just created

  • Run

Useful: Scripting Overview

Jimmy this script is great, and was hoping it was cure my ailment. Unfortunately I didnt have luck. I recently deployed 6 new assets on a new customer. Usually I get a check in from spashtop about a new device added and can access said assets via the splashtop dropdown. For some reason the connection was never made despite the asset working fully with the backgrounding tools/remote connection feature. When I hit the Remote Access button I get

Screenshot 2022-09-12 103735

So I thought your script would be perfect to fix this, However upon running it I received this output. Any suggestions are welcome and thank you!

error> Invoke-WebRequest : The underlying connection was closed: An unexpected error occurred on a send.
error> At C:\ProgramData\Syncro\bin\e9000694-c9e9-40a4-95b3-7c094a57d628.ps1:15 char:5
error> + Invoke-WebRequest -Uri $url -OutFile $file
error> + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
error> + CategoryInfo : InvalidOperation: (System.Net.HttpWebRequest:HttpWebRequest) [Invoke-WebRequest], WebException
error> + FullyQualifiedErrorId : WebCmdletWebResponseException,Microsoft.PowerShell.Commands.InvokeWebRequestCommand
error>
error> start-process : This command cannot be run due to the error: The system cannot find the file specified.
error> At C:\ProgramData\Syncro\bin\e9000694-c9e9-40a4-95b3-7c094a57d628.ps1:18 char:9
error> + start-process -wait -Filepath $file -ArgumentList "preverchec …
error> + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
error> + CategoryInfo : InvalidOperation: (:slight_smile: [Start-Process], InvalidOperationException
error> + FullyQualifiedErrorId : InvalidOperationException,Microsoft.PowerShell.Commands.StartProcessCommand
error>
Deleting Installer
error> Remove-Item : Cannot find path ‘C:\temp\streamer.exe’ because it does not exist.
error> At C:\ProgramData\Syncro\bin\e9000694-c9e9-40a4-95b3-7c094a57d628.ps1:21 char:9
error> + Remove-Item -path $file
error> + ~~~~~~~~~~~~~~~~~~~~~~~
error> + CategoryInfo : ObjectNotFound: (C:\temp\streamer.exe:String) [Remove-Item], ItemNotFoundException
error> + FullyQualifiedErrorId : PathNotFound,Microsoft.PowerShell.Commands.RemoveItemCommand
error>

It’s erroring on the download. I’m thinking that maybe you’re not using TLS 1.2. Try forcing TLS 1.2 with the below script.

Set-ItemProperty -Path 'HKLM:\SOFTWARE\Wow6432Node\Microsoft\.NetFramework\v4.0.30319' -Name 'SchUseStrongCrypto' -Value '1' -Type DWord

Set-ItemProperty -Path 'HKLM:\SOFTWARE\Microsoft\.NetFramework\v4.0.30319' -Name 'SchUseStrongCrypto' -Value '1' -Type DWord

Usually a tls issue. You can throw this in the script just before the Invoke-WebRequest line and it should help.

[Net.ServicePointManager]::SecurityProtocol = “tls12, tls11, tls”

Edit: @Jimmie Is fast lol. That works too.

That’s one way of doing it, I just didn’t want to throw that in every script that downloads lol. I’m curious why this isn’t automatically forced by MS by now. They force everything else on us.

Yea totally understand that. And you’re right, I have no idea why they don’t force it like they do everything else lol.

I tried this Jimmy with the same results. I also added the other variable @mgiordano suggested to no avail as well. Id just uninstall and reinstall syncro with the asset installer, but that requires a reboot and I was trying to do this remotely without messing up this clients day.

Appreciate your (super fast) reply earlier.

I just tested and was able to download, so it’s something on that machine. You’ll need to look up “Invoke-WebRequest : The underlying connection was closed: An unexpected error occurred on a send.” and see if any of the fixes work. The other thought would be what version of PS is it using. You can run $PSVersionTable, if it’s not 5.1, it needs to be upgraded.

5.1 checked out good. Going through stack overflow and other searches on this error. The general gist seems to be the TLS version. Ill keep at it and thank you.

@john9 First off, apologies for Hijacking your thread! There were so few topics on this matter in the forums so I hope this is helpful to someone else in the future!

@Jimmie @mgiordano Thank you for steering me in the right direction. Turns out it wasn’t TLS at all. Jimmies script works perfectly once our firewall isn’t blocking the file download! Modified your original script to use a file hosted in Syncro, which also failed but with similar errors. Attempted to manually download the file in a web browser on the asset and immediately knew the issue was firewall related. A recent firmware update made things much more strict for this particular product line.

Found this in my WatchGuard firewall logs: 2022-09-12 12:24:05 Deny 192.168.100.158 143.204.165.29 Splashtop 49401 443 PRIVATE External Application identified 557 128 (HTTPS-proxy-00) proc_id=“firewall” rc=“101” msg_id=“3000-0149” src_ip_nat=“67.244.132.109” tcp_info=“offset 5 A 1210911244 win 5152” app_name=“Splashtop” app_cat_name=“Remote access terminals” app_id=“51” app_cat_id=“11” app_beh_name=“Access” app_beh_id=“6” action=“Global” geo_dst=“USA” sig_vers=“18.228”

Firewall was going to be my last suggestion but I got sidetracked. The thing you mentioned was that it was all the computers at that location. Assuming you found the page for all of Syncro’s domains to whitelist?

I havent found that particular page yet (or needed it thankfully) - this was a WatchGuard Firewall appliance specific issue. Most all of our business clients use them and I would have hit this issue before now if it was a simple whitelist issue. WatchGuards most recent firmware update put in a whole bevvy of default apps and services it blocks now in their default outgoing policy. I had just installed said firmware on this newly deployed firewall before I installed the asset installers for this new customer.

If you need it, here’s the page: Syncro Exceptions and Allowlists

1 Like