MacOS Agent - Tray/Bar Icon Not Showing in New User Profiles


Not sure if this is a known issue or not but here’s the rundown:

I have a couple of Mac agents deployed in an environment with the policy set to show the RMM icon in the top bar so users can click on it to create a ticket. This worked fine on initial deployment and still works in the user accounts that were there initially.

Recently, the environment has changed and new user profiles were added to the machine (moving from stand-alone to an active directory setup). In these new profiles the RMM icon doesn’t ever show up and therefore, those users can no longer create tickets. I’ve checked the privacy settings (disk access, etc) and they appear normal/allowed still and Syncro is running (ie: it sees the machine online, I can run scripts, can remote in through Splashtop) it’s just the icon that’s missing. I’ve tried switching and changing policies but that hasn’t worked. Is there any way to bring this icon back?


Still looking for a solution. I can try uninstalling/reinstalling the agent but I’d rather not be forced to do that on dozens of devices.

1 Like

Have you opened a support ticket?