Intermittent Syncro UI sluggishness

,

Hello everyone! Have any of you been experiencing random intermittent slow load times/performance when using Syncro over the last month? Everyone in our team has experienced this throughout July and into this month on all computers at different times. Different locations with different Internet connections hasn’t made a difference, which rules out ISP issues. It seems like the slowness generally last 5-15 minutes. Closing all other Internet browser tabs and clearing Internet browser cache and cookies hasn’t ever helped. All our computers are running NVMe or SATA SSD’s, 8th gen or newer Intel Core processors, at least 8GB of memory, fully updated Windows 10/11 OS’s and Chrome/Edge browsers, and we’re on a symmetrical gigabit fiber optic Internet connection with most computers on wired gigabit Ethernet. None of our other web apps have this problem. I’ve contacted Syncro support on this twice, but both times they said there have been no issues on their end and by the time they get to the ticket the intermittent issue isn’t acting up and they say they can’t repeat it. If this is an issue many of you have been putting up with, you’re not alone. I’m hoping we can share enough details from our experiences that Syncro is able to identify the root problem and fix it for good.

1 Like

For starters, I think overall Syncro knows and has been increasing their backend resources and moving hosting in order to improve overall performance of the platform.

With that said, unless it’s all the time to the point it’s becoming an issue, I think it’s normal to a degree to see small “blips” if you were, where something might take a little longer than usual to run. From time to time, on most RMM platforms I’ve used in the past and currently use, there will be times when the platform seems a bit slow to respond versus most other times.

If it’s more than just here and there, then perhaps you do have a specific issue and I would definitely stay on support about it.

Thanks mgiordano, that sounds good. Has Syncro posted any news about switching hosting or building backend resources? I’ve looked but haven’t seen anything.

The issue has definitely gotten worse over the last several months, notably July/August where the delays are occurring every other or every few days and are to be 10-15 seconds each time. It’s like trying to use a computer with a failing hard disk drive. LOL. We used to use Pulseway and I don’t remember any issues to this extent. Maybe part of the issue is that Syncro has so many features and its database is huge and needs optimizing? Pulseway was just an RMM, Syncro is an RMM, PSA, CRM, Inventory system, etc.

I suppose my last resort with Syncro support might be to screen record the issue. Hopefully they are upgrading the backend and the issues will be back back to minor delays.

Yea they have made several posts regarding optimizing and expanding resources over the last couple months, and one post about changing hosting.

I use to use Pulseway as well with a dedicated instance, and I would get timeouts actually here and there, but not often. But also yes, Pulseway has a lot less going on as well lol. Couldn’t wait to get away from them though, personally, haha.

Here is the post about hosting, as well as one about performance issues.

Platform Investments

Performance Issues

And this section in general is where you’d want to browse for more info about what’s happening with the platform. I know they just fixed a pretty bad issue where chat was super slow and often not loading correctly.

Platform Announcements

Thanks for providing those links! Nice to see they are working on the service infrastructure. I suppose it may be another month of two of getting all the bugs out of all the accounts after the major upgrade, so I’ll try to be patient. :innocent:

Yeah, same here. Things started out well with Pulseway for us, but support and account managers kept getting worse. And their PSA is not even close to Sycnro. Plus the whole issue of only having 3 days a month to reduce your account license seat pool to stop paying for seats you weren’t using. :roll_eyes:

Yes! I did see the chat issue both in person and their fix. :grin: That was a nice quick response from the Syncro team.

Thanks again for your help mgiordano. I’m really encouraged that progress is being made.

Have a great day!

1 Like