Ignore Splashtop Sound Driver


Every time I install Splashtop on a Mac and make the first connection, I am prompted to install the sound driver (we don’t support PCs so I don’t know if this is also an issue with those). I can dismiss this box, but then every single time I connect to the Mac it pops up again. I have no choice but to continue seeing this box or to install the sound driver, but this means when I connect I’m blasted with whatever they’re listening to, or worse yet if our call is running on their end on a soft-phone we end up in a horrendous feedback loop until I quickly mash the mute button on my own Mac.

Can this sound driver be disabled by default? I really, really don’t want it.

If it can’t be disabled by default, can this please be considered as a feature request.

Have you tried going into settings on the splashtop streamer app? The same thing you go to when you have to assign permissions.

Under the second tab, settings, there’s an option that says output sound over the remote connection only or output sound only on this computer.

Don’t know if that changes at each login or not, but might do what you’re asking, even if it means changing the setting on each machine once.

Yeah that does stop the sound playing, but involves manually connecting to the Mac, opening Splashtop, changing the settings one by one, something I’m not keen on doing for 300+ agents unless it can be scripted. That doesn’t fix the whole issue though, as the driver installer window keeps coming up when I remotely connect even if I change that setting.

Yes Please! Hate that annoying sound driver.

For our PC we have an onboarding script user sets Regustry value AutoMute for Splashtop. (https://support-splashtopbusiness.splashtop.com/hc/en-us/articles/360030993692-What-are-the-Windows-Streamer-registry-settings-)

I wonder if there’s a similar setting you could use on Mac OS.