Error trying to create device - Windows 7 Syncro Installation

I have two computers that require Windows 7 OS. Fresh OS. No updates aside from SP1. Firefox installed and NET 4.8.

When I try to run the syncro installer, I get an error: “Error trying to create device. please contact support for assistance.”

Any ideas?

Error

Hi Sterling! Generally this is a communication error. When checking the install logs you’ll often see "The request was aborted: Could not create SSL/TLS secure channel."

Logs for the installer are located on the asset under C:\ProgramData\Syncro\logs

In your case, I would recommend updating it to SP2 if possible.

Things to check…
• Is this being installed on a supported OS? https://help.syncromsp.com/hc/en-us/articles/115002535954-Installing-a-Syncro-Agent-on-a-Device#minimum_requirements
• Is .NET 4.6.2 or higher installed and updated?
• Configure the whitelist:
https://help.syncromsp.com/hc/en-us/articles/360006048034-Syncro-Exceptions-and-Whitelists
• Ensure you’re using a new installer, if you’re installing from a file you’ve downloaded some time ago, download a fresh one by clicking ‘Add Asset’ from the Asset page.
• Attempt installing in another way, if you were using the EXE try the MSI and if the MSI, try the EXE.

If you need to do a fresh reinstall, an uninstallation tool can be found at the bottom of this page- you will need to reboot after uninstalling. https://help.syncromsp.com/hc/en-us/articles/115002535954-Installing-a-Syncro-Agent-on-a-Device#troubleshooting

If there is any other software that may interfere with the network connection or the installation of files this will be an area to check.

The SP2 package fixed it.

I had forgotten about the SP2 pack for Windows 7. :sweat_smile:

Thank you!

Excellent, glad to hear that solved it! :slight_smile:

Use iiscrypto by nartec to correct the registry keys for tls 1.2 . Use the best practices setting and reboot. the agent will install after that. this fixed 2 of my issues that support could not fix for over 3 months.