Date format in Syncro

The date format for the Field Type in Asset custom field has the format of MM-DD-YYYY
How to I set the date format to be DD-MM-YYYY to better suit us in Australia?

It would be nice if this simply happened by configuring General Settings to be Australia
image

I feel you. I have been after ISO 8601 dates in Syncro for years. YYYY-MM-DD is the only umambiguous date format, but there is no way to make Syncro use it.

agree, YYYY-MM-DD is by far the best option and most logical option.
But failing that, the displayed date format should at least match the culture of the user or the MSP.