Chrome not updating with update policy

Having an issue where all of our clients are set to “Update if present” for Google Chrome but multiple endpoints in nearly all of our customers are way out of date, some of them are 11 versions old. The endpoints have been online and connected just fine, have clearly been restarted at times too but it is not updating. Is anyone else experiencing this issue or have a fix? This is rather time sensitive especially with the new exploit found recently and we’d like to ensure our clients stay protected

Most likely Chrome wasn’t installed via Chocolatey, so it can’t manage it. You can force an install via

choco googlechrome install -y -f

After that, it will keep it updated. You can also run a choco script on a schedule to keep things updated

choco upgrade all 
3 Likes

Google Chrome should be automatically adopted as it’s one of the supported options in Syncro, but weird things happen, so it’s possible. There could also be issues with the Chrome installation itself. You can check the chocolatey logs in c:\programdata\chocolatey\logs or check syncro’s logs in c:\programdata\syncro\logs or check the asset and see if any 3rd party patching is happening or if it’s just chrome that’s the issue. That should lead you to the root issue.